Jump to content

Sign in to follow this  
Brent

Posting a picture in a forum discussion

Recommended Posts

How does one insert a picture into a forum discussion note?

I tried pasting, but get an error message that file is to large. I havent figured out how to compress the photo.

Second question: How does one link from a discussion thread to a note in the gallery section?

Share this post


Link to post
Share on other sites

I'm actually looking for a better way to do this, but here goes:

Click on the picture to maximize it in the Gallery, and then right click and select "Properties". Highlight the "Address/URL" by clicking and dragging on it starting at the "http://" ... it will scroll down so you get the entire URL highlighted, including the ".jpg" file extension at the end. Press CTRL-INSERT or Edit*Copy from the menu, and click CANCEL.

The URLs are still pretty long, and look something like this:

http://www.messing-about.com/~fshagan/photopost/data/500/75P2170045-med.jpg

To insert it into a forum message, start entering the message and click the "Img" button on top of the "Post a Reply" form, press SHIFT-INSERT or Edit*Paste to copy the URL in the message, and then click the "Img*" button again to close the tag. It works like this:

75P2170045-med.jpg

I'd love to get a way for users to select a pic to install from within the message post, but so far haven't found it. So for now, we have this awkward, round-about way of doing it.

Share this post


Link to post
Share on other sites

And the other way is to upload the photo to our server. But that's where you do run into file size limitations. If its over a certain dimension, it will appear as a link instead of a picture (so it doesn't slow down forum loading for everyone else), and if its over a certain size it isn't allowed to save disk space. I'll see if there's an "auto-resizer" I can install to automatically make the picture an allowable size and store it on the server.

Share this post


Link to post
Share on other sites

To put a link to a forum topic in a Gallery picture comment field, copy the forum topic URL and then insert it in the Gallery comment field, along with your other comments. Clicking on it will open the forum topic in a new window.

You can go the other way, providing a link to a particular picture and its comments in the Gallery by copying the URL and pasting it in the message ... and then highlighting it and clicking the "URL" button to make it into an active link: http://www.messing-about.com/photopost/showphoto.php?photo=42

The URL is found in your browser's address bar when you are viewing the Gallery page or forum topic.

Share this post


Link to post
Share on other sites

Frank,

I was wondering if you might know why I can't see many of the pictures that are posted. I think that it is something wrong with the network that I am using. I am using computers that are set up through my schools systems. I think that they are using T1's. I don't think that it is anything on your end because everyone else seems to be able to see the pictures. I realize that this is not your problem but I was hoping that you might have some idea if there is some settings or something that I can change to make the pictures load.

Thanks for all the time you spend on this forum. I really enjoy it.

Chris

Share this post


Link to post
Share on other sites

Thanks for the quick response Frank. I forgot to mention that I am using microsoft internet explorer. I remembered you saying that you had had some trouble with netscape, I assumed that meant that you were not having too much trouble with microsoft. That is kind of why I thought that it was unusual that I was having trouble.

Chris

Share this post


Link to post
Share on other sites

Yeah, that's strange. It may be something on your end; all the versions of IE that I have used to test work OK with the gallery.

If you want to do a test, check out this link to see if the pictures show up:

http://www.pondresource.com/forum/modules.php?op=modload&name=gallery&file=index

Its on my water gardening site I'm just getting started, and uses a different picture gallery software. You should be able to see four albums there. If you can, then its probably some combination of the software here and your firewall or other setup on your T1 at work.

Share this post


Link to post
Share on other sites

Thanks again Frank for your help. I could see the pictures on your website. I think that maybe I did not phrase my problem clearly. It is not the gallery on this site that I am having trouble seeing. The pictures that I cannot view are the ones that are posted in the forums. For example I can see the picture that you put in this topic put the pictures that Capt Jake put in the topic "finished pics" on the main forum will not load for some reason. Sorry for the confusion. Looking at my original question I can see that it was pretty vague.

Chris

Share this post


Link to post
Share on other sites

Sorry, Chris! I completely misunderstood!

The "inline" pictures sometimes come up "broken" for me too. I think it sometimes depends on the server they are on. Each time you open the message, it has to fetch the image from the other server. Some sites employ blocking techniques that don't always work. You can right click on the image and select "Show Picture" to see if it will load it again. Or you can copy and paste the "Location" (which is a URL) into a browser window to see if you can surf to the site and see the pic.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.