Jump to content


Forum problems? Contact Frank • Like our Facebook Page

Photo
- - - - -

Unable to view pictures in message body


  • Please log in to reply
4 replies to this topic

  #1 cabbie_caesar

cabbie_caesar

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 22 December 2006 - 03:45 PM

Hello All,

I can see all Avatars and buttons, but I cannot view MOST pictures imbed in the message body. In place of the photo I see a table with the photo title, description and size. I do see the photos posted by a certain gentleman from California, and I can see the pictures in the gallery.

I'm running Windows XP and Zone Alarm Firewall/Anti Virus. I've turned off Pop up blocking, and have added the site to the allowed list. Additionally, I've allowed all cookies and turned security to minimum.

Thanks for any suggestions.

Cabbie.

  #2 Frank Hagan

Frank Hagan

    Advanced Member

  • Administrators
  • 3,779 posts

Posted 23 December 2006 - 12:32 AM

Are you getting anything inside the table? Like the "broken picture" icon (red "X", or anything like that)?

Some of the security software doesn't like the way the pictures are presented in the forums for some reason, but ZoneAlarm isn't one of the ones that I usually associate with having problems.

Which browser are you using? Internet Explorer or Firefox? (Or one of the others?)

  #3 Frank Hagan

Frank Hagan

    Advanced Member

  • Administrators
  • 3,779 posts

Posted 23 December 2006 - 02:01 AM

Here are some step by step procedures for three of the firewalls that seem to have a problem with "referers" ... the way the pictures are displayed in the forums:

McAfee Security Suite
1. Click "Privacy Service"
2. Click "Protect my identity"
3. On the right margin click the line that says "I want to . . . protect identity information"
4. Click the tab that says "CleanSlate" and deselect "Prevent 'referer' information from being shared"


Norton Internet Security
1. Open Norton Internet Security.
2. Click "Options".
3. Click "Internet Security".
4. Click the "Advanced Options" button.
5. Click the "Privacy" tab.
6. Change Referrer (under Browsing Privacy) to "Permit"
7. Click "OK".
8. Click "OK" again.
9. Close Norton Internet Security and the pictures should show up.

Zone Alarm
1. Open the Zone Alarm configuration panel (Double click on the Zone Alarm icon on the bottom right of your Windows Taskbar, or open Zone Alarm from the "Start" and "Programs" menu.)
2. Select the "Privacy" menu on the left hand side.
3. Click on the button labeled "Custom", in the "Cookie Control" section
4. Remove the tick from "Remove Private Header Information".
5. Click "OK"
6. Close the Zone Alarm configuration panel.

See if those help if you have any of those programs. The ZoneAlarm info might help, as I think you said you disabled the pop up or ad blocker (which is sometimes the problem).

  #4 cabbie_caesar

cabbie_caesar

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 23 December 2006 - 10:12 AM

Thanks Frank and Others,

I had to disable Zone Alarm Ad Blocking and follow the instructions that Frank listed about Cookie control.

Thanks again,

Cabbie

  #5 Frank Hagan

Frank Hagan

    Advanced Member

  • Administrators
  • 3,779 posts

Posted 23 December 2006 - 01:42 PM

I read a good explanation of what is happening.

When you link a pic in from another site, it actually retrieves that picture every time someone views the page. So if someone linked in a pic from one of our messages to a very busy forum, such as the Wooden Boat Forum that gets thousands of views per day, we would quickly use up our allotment of bandwidth for the month. In order to save bandwidth, we don't let other websites link our pictures into their forums, etc. You have to be on the messing-about.com site to see the pics (or another site I've allowed).

The way the software does that is that it looks for the "referrer" header. The referrer header basically tells the web server where it was one step before asking to see the picture. If the exchange happened in English, it would look like this: When your browser asks for the page from the web server, the web server says "Hey, where were you last?" The browser answers and says "I was on messing-about.com clicking the link to see this message". The web server says "OK, I'll show you this picture."

Some privacy software allows you to block the web server saying "Hey, where were you last?" because there is a chance someone could use that to track your surfing habits. So when the web server says "Hey, where were you last before I show you this picture" and your security software says "I'm not gonna' tell!", then the web server says "Fine, then you can't see my pictures."

The steps above allow you to either "whitelist" messing-about.com so the pictures can be seen, or tell you how to turn off blocking any content that looks for the referrer header.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users